engine trouble - Kawasaki Versys Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 02-06-2010, 02:39 PM Thread Starter
Member
 
Join Date: Feb 2010
Posts: 1
engine trouble

can any one help, my versys hasan intermitant fault that leaves my mechanic scratching his head. when im cruising between 4 to 5000 revs the engine will sudenly lose power but not cut out, i then give it some throttle and away it goes. then again it chug if fuel is thr issue than it will be fine the problem is not constant and onboard ECUreads no faults im at a loss any help?
jason is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-06-2010, 03:58 PM
Member
 
Join Date: Jun 2009
Location: Henderson, cty, TX
Posts: 459
TPS or fuel filter if still hitting on both cylinders????
jcctx is offline  
post #3 of 7 (permalink) Old 02-06-2010, 05:40 PM
Member
 
Join Date: Jun 2008
Location: Evansville, IN
Posts: 364
Tank vent hose pinched?
Shatrat is offline  
 
post #4 of 7 (permalink) Old 02-07-2010, 02:51 AM
Member
 
stlee29's Avatar
 
Join Date: Dec 2008
Location: Bukit Mertajam,Penang,Malaysia
Posts: 3,187
Hi Jason,

Is your idle at 1300 rpm steady? What's your mileage?
Possible cause:
1. Fault spark plugs
2. Faulty ignition coil
3. Dirty fuel injectors
4. Dirty fuel filter


My V Blog:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Ride safe,
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
stlee29 is offline  
post #5 of 7 (permalink) Old 02-07-2010, 11:02 AM
Member
 
Join Date: Feb 2010
Location: Ky
Posts: 1
Quote:
Originally Posted by jason View Post
can any one help, my versys hasan intermitant fault that leaves my mechanic scratching his head. when im cruising between 4 to 5000 revs the engine will sudenly lose power but not cut out, i then give it some throttle and away it goes. then again it chug if fuel is thr issue than it will be fine the problem is not constant and onboard ECUreads no faults im at a loss any help?
A coworker of mine purchased a new zx14 and it had a similar problem. It would idle fine but while going through the gears it would pull hard then slow down and do it rather abruptly. They dealer changed some electronic items with no luck. The dealer finally checked the pressure from the fuel pump and that was the problem. The fuel pump was not holding steady pressure, they replaced it and no more problems. Hope this helps.
dreambike is offline  
post #6 of 7 (permalink) Old 02-08-2010, 12:22 AM
Member
 
invader's Avatar
 
Join Date: Mar 2008
Location: Kapuskasing Ontario Canada
Posts: 7,815
Possibly a bad fuel pump, a short in the main harness from the main switch, or maybe a cracked/leaking coil-over-plug... What's your mileage?
invader is offline  
post #7 of 7 (permalink) Old 02-08-2010, 06:16 AM
Member
 
Join Date: Dec 2009
Posts: 2
My bike has done the same thing but after hundred miles the fi light stayed on for five mins,fault code eventually showed up the oxygen sensor at fault, explained why it happened intermittently. Turning off the ignition and starting it again cured it temporarily, this ruled out bad petrol pinched hoses etc Hope this helps
Christi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome